WLAN-Repeater für Reisen

Ausgangssituation

Der mAP lite bietet sich wegen seiner Größe als perfekter Reiserouter/Repeater an.

Gerade in Hotelzimmern ist die WLAN-Abdeckung (in der Regel) nur am Zimmereingang gut, da sich die Access Points am Flur befinden.
Abhilfe schafft hier ein kleiner WLAN-Repeater, der zum einen WLAN-Client im Hotel-WLAN ist und zum anderen sein eigenes WLAN-Netz abstrahlt.

Ein klassischer Repeater, der den Datendurchsatz zwar halbiert, aber es geht um die Funkausleuchtung und nicht um den höchsten Durchsatz – der in Hotels sowieso oft fragwürdig ist.

klassische WLAN-Ausleuchtung in Hotels (orange)

Hotelflur mit Access-Point an der Decke – der Empfang ist nur am Zimmereingang gut

mit WLAN-Repeater
WLAN-Ausleuchtung mit Repeater (rot)

Folgendes muss konfiguriert werden:

  • WLAN-Client im Hotel-WLAN
  • WLAN-Access-Point für den Management-Zugriff
  • WLAN-Access-Point für die Repeating-Funktion

Der mAP lite besitzt ein 2,4GHz-WLAN-Interface – das Master-Interface – auf diesem können mehrere Slave (Virtual) Intefaces angelegt werden.

 

WICHTIG: Die WLAN-Client-Funktion (Station-Pseudobridge) muss zwingend auf dem Masterinterface angelegt werden!!
Würde sie auf einem Slave angelegt werden, würde sie sich nicht verbinden!

 

Nun kommt folgende Einschränkung zum Tragen. Kommt man im Hotel an, ist das Masterinterface (WLAN-Client / Station-Pseudobridge) normalerweise nicht richtig konfiguriert. Das kann kaum vorab gemacht werden (welche ESSID, welche/ob Verschlüsselung, welcher Key… sollte man eintragen?).

Über den Management-Zugriff muss dies einmalig gemacht werden. Allerdings arbeiten Salveinterfaces nicht, wenn das Masterinterface nicht läuft! Hier entsteht ein klassisches Henne-Ei-Problem: Das Management-Netz wird ohne richtig konfigurierten Master nicht aktiv, welcher nur über den Management-Zugriff konfiguriert werden könnte.

Man könnte nun mit einem zweiten mAP oder einem kurzen LAN-Kabel und einem USB-LAN-Adapter fürs Handy arbeiten. Aber das ist alles nicht wirklich praktikabel.

 

Die Lösung ist einfach:

Man hinterlegt auf dem Masterinterface keine feste SSID. Stattdessen legt man eine Connection-List an. Diese werden sequenziell von oben nach unten abgearbeitet. Als erstes legt man hier den mobilen HotSpot seines Handys an. Aktiviert man diesen, verbindet sich der mAP immer mit dem eignen Handy. Über diese Verbindung kann nun der zweite Eintrag der Connection-List bearbeitet werden (das Hotel-WLAN). Schaltet man den Handy-HotSpot ab, verbindet sich der mAP automatisch mit dem Hotel-WLAN. Es bietet sich an sowohl mit Connection-Lists als auch mit Security-Lists zu arbeiten.

WLAN1 (Master) – das Masterinterface (Client im Hotelnetz)

 

WLAN2 (Slave) – WLAN-Repeater
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=auto \
mode=station-pseudobridge ssid=""
add disabled=no keepalive-frames=disabled mac-address=4A:8F:5A:XX:XX:XX \
master-interface=wlan1 multicast-buffering=disabled name=wlan2 \
security-profile=Server1 ssid="mein Repeater" wds-cost-range=0 \
wds-default-cost=0 wps-mode=disabled

 

Connection-List:

/interface wireless connect-list
add interface=wlan1 security-profile=HotSpot1 ssid=AndroidAPXYZ123 \
wireless-protocol=802.11
add interface=wlan1 security-profile=Client1 ssid=HOTEL-WLAN \
wireless-protocol=802.11

Security-List:

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk mode=dynamic-keys name=Client1 \
supplicant-identity=""
add authentication-types=wpa2-psk mode=dynamic-keys name=HotSpot1 \
supplicant-identity=""
add authentication-types=wpa2-psk mode=dynamic-keys name=Server1 \
supplicant-identity=""

Als letztes legt man eine Bridge an und fügt WLAN1 und WLAN2 als Ports hinzu. Damit vereint man die beiden Layer2-Segemente:

/interface bridge
add name=BR0 protocol-mode=none
/interface bridge port
add bridge=BR0 interface=wlan1
add bridge=BR0 interface=wlan2

 

WICHTIG: WLAN-Netze die versteckt sind, werden über die Connection-List nicht gefunden!

 

Testlauf

Mobilen HotSpot am Handy aktivieren:

 

 

Der mAP verbindet sich als Client mit dem Handy-HotSpot (erste Position der Connection-List):

 

Nun kann man via Handy den mAP konfigurieren und die Einstellungen des Hotel-WLANs anpassen:

 

 

Hat man die Konfiguration abgeschlossen, beendet man den Handy-HotSpot.
Damit durchsucht der mAP wieder seine Connection-List und findet (an zweiter Position in der Connection-List) das Hotel-WLAN und verbindet sich:

 

Nun wird auch das Salve-Interface aktiv und sendet seinerseits das eigentliche Repating-Netz aus mit dem man sich verbinden kann:

 

Aus Sicht des Hotels taucht der WLAN-Client ganz normal auf:

Client aus Sicht des Hotel-DHCPs

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.